`
Coco_young
  • 浏览: 119183 次
  • 性别: Icon_minigender_1
  • 来自: 湖南长沙
社区版块
存档分类
最新评论

POJ_2586 Y2K Accounting Bug

阅读更多
Y2K Accounting Bug
Time Limit: 1000MS  Memory Limit: 65536K
Total Submissions: 5785  Accepted: 2796

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.
Input

Input is a sequence of lines, each containing two positive integers s and d.
Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.
Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit

题目大意:某公司每个月都会盈利或者亏损,盈利的金额为s,亏损的金额为d,该公司每连续5个月报一次财政状况,即(1-5,2-6,3-7,4-8,5-9,6-10,7-11,8-12),这八次报账都显示公司为亏损,问,该公司年底最多能盈利多少,如果不能盈利输出Deficit。

分析:由于每5个月的报账都为亏损,所有连续的5个月里至少有1个月为亏损,则可能产生最优解的情况为如下4种
1 2 3 4 5 6 7 8 9 10 11 12
s s s s d s s s s d  s  s //每5个月里只有1个月亏损
s s s d d s s s d d  s  s //每5个月里只有2个月亏损
s s d d d s s d d d  s  s //每5个月里只有3个月亏损
s d d d d s d d d d  s  d //每5个月里只有4个月亏损
从上到下一次枚举四种情况,如果满足条件(每次报账都为亏损),则算出ans = (盈利的月数)*s - (亏损的月数)*d,若ans>0 则输出 否则输出Deficit;若上述4种情况都不满足,则直接输出Deficit.

代码:
#include<iostream>
using namespace std;
int main()
{
    int a,b;
    while(cin>>a>>b)
    {
        int ans = 0;
        if(4*a-b<0)
        {
            ans = 10*a-2*b;
        }
        else if(3*a-2*b<0)
        {
            ans = 8*a-4*b;
        }
        else if(2*a-3*b<0)
        {
            ans = 6*a-6*b;
        }
        else if(a-4*b<0)
        {
            ans = 3*a-9*b;
        }
        else
        {
            ans = -1;
        }
        if(ans>0)cout<<ans<<endl;
        else cout<<"Deficit"<<endl;
    }
    return 0;
}

0
2
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics